블로그에 TLS 1.3 적용함

블로그 서버에 TLS 1.3을 적용했습니다. 약 2년 전에도 시도 했었는데 그때는 지원되는 브라우저가 별로(?) 없어서 적용했다가 도로 1.2로 내렸는데.. 이제는 대부분 지원하기 때문에 적용했습니다.

솔직히 별 생각 없었는데 인터넷 돌아다니다가 이런 뉴스를 봐서 말이죠.

ㅋㅋㅋㅋㅋ 중국이 검열 피해갈수 있는 TLS1.3이나 ESNI를 쓰는 트래픽을 차단한다고 하니 이제 제 서버도 나름 클린(?) 해지겠네요 ㅋㅋㅋㅋㅋㅋㅋ

대신 접속 가능한 브라우저가 위에서 아래로 줄어들긴 하지만…

어차피 구버전 웹브라우저였으니 과감하게 다 버립니다!!!

세팅하다가 하나 nginx 버그(?) 발견했는데

ssl_protocols TLSv1.3;

이 항목은 원래 http, server 둘다 사용가능하다고 써 있는데 막상 써보면 server에 넣으면 작동을 하지 않습니다. 이거 때문에 한참을 삽질했는데 일단 버그라 생각하고 http 구문에 넣어서 사용중입니다.

댓글 달기

이메일 주소는 공개되지 않습니다.